View unanswered posts | View active topics It is currently Wed Mar 20, 2019 9:39 pm



Reply to topic  [ 1 post ] 
 TWGS Under RAID 
Author Message
Private 1st Class

Joined: Tue Feb 27, 2001 3:00 am
Posts: 2
Unread post 
Over at The Void we've been experiencing a rather odd problem...

Our "Turbo" server is a dual-550 mhz HP NetCenter machine, 1 gb RAM, running TWGS on a RAID array off an Adaptec RAID controller with 64 mb of onboard disk cache. The server runs like a banshee, and was even able to support almost 100 simultaneous connections without so much as a hiccup not too long ago.

The problem comes at Extern. It takes anywhere from 2 to 3 minutes per game for Extern to run, and during this time lag becomes so horrendous it can take as long as ten seconds for a player to get a "Who's Online" report of only a couple lines.

I recently set up a second machine, a single processor system, but using the same model Adaptec RAID controller and drive brand/models, with duplicate RAID array configurations. The problem persisted on the test machine. I wiped the system clean, reverted back to a standard daisy-chain SCSI setup and reinstalled a copy of the active TWGS server. After the conversion, Extern for all four games ran in under 20 seconds.

Thinking it might be the Adaptec card I installed a HP NetRaid card, wiped the machine again and reinstalled from the ground up. The Extern lag reared its ugly head again.

It's almost embarrassing to have our P90-based TWGS server run Extern on six games several minutes faster than our 1.1 ghz "Turbo" server can run Extern on four games.

I'm at a loss here. In my extensive experience with RAID architecture, the RAID should be transparent to any software operating above the system level. So why the drastic differences in Extern run time between a standard SCSI configuration and a RAID configuration?

Any Sysops out there running TWGS on a RAID array? If so, what kind of RAID controller and drives are you running? Ever see this problem before? Anyone have a magic wand I can wave over the server box?


Mon Mar 26, 2001 11:10 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware.