View unanswered posts | View active topics It is currently Sun Sep 24, 2017 10:53 am



Reply to topic  [ 15 posts ] 
 TWGS in Windows 7 x64 (service) 
Author Message
Veteran Op

Joined: Thu Jun 09, 2011 9:40 pm
Posts: 23
Unread post TWGS in Windows 7 x64 (service)
Has anybody else had an issue setting up TWGS as a server in the latest (v2.00) release?

I can install the service (as admin) but it will not start. When I try and start it is gives me error 1053. I have uninstalled and reinstalled to no avail..... :(


Thu Jun 09, 2011 9:44 pm
Profile
Site Admin
User avatar

Joined: Sun Dec 24, 2000 3:00 am
Posts: 3150
Location: USA
Unread post Re: TWGS in Windows 7 x64 (service)
I have had reports of this. I am unable to reproduce this problem, but I have modified the way TWGS runs as a service, so I'd like to see if that makes a difference. I'll be releasing an update soon, so give that a try and let me know if it helps. If it doesn't, I'll take a deeper look at this.

_________________
John Pritchett
EIS
---
Help fund the TradeWars websites! If you open a hosting account with A2 Hosting, the service EIS uses for all of its sites, EIS will earn credits toward its hosting bill.


Thu Jun 09, 2011 11:29 pm
Profile WWW
Site Admin
User avatar

Joined: Sun Dec 24, 2000 3:00 am
Posts: 3150
Location: USA
Unread post Re: TWGS in Windows 7 x64 (service)
I'm doing some research on this problem, and I found a reference to a generic problem with people having this error on services. Here's what was suggested:

"To resolve this problem, obtain the latest service pack for the Microsoft .NET Framework 1.1. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
885055 (How to obtain Microsoft .NET Framework 1.1 Service Pack 1 ) How to obtain Microsoft .NET Framework 1.1 Service Pack 1"

I have no idea if it's related, but maybe worth a try just to rule it out?

EDIT: Further reading shows that this hasn't been an effective solution. But something I would like to rule out is whether or not you've tried running TWGSSERVE.EXE as an administrator? Even if you're logged in as an administrator, try running TWGSSERV.EXE explicitly as an administrator. Also, maybe run it in XP compatibility mode? Just some thoughts.

I'm fairly convinced that this is caused by TWGSSERV.EXE trying to start a service without sufficient rights. I wonder if it's possible to start the service from the service list rather than from TWGSSERVE.EXE?

_________________
John Pritchett
EIS
---
Help fund the TradeWars websites! If you open a hosting account with A2 Hosting, the service EIS uses for all of its sites, EIS will earn credits toward its hosting bill.


Fri Jun 10, 2011 12:35 am
Profile WWW
Veteran Op

Joined: Thu Jun 09, 2011 9:40 pm
Posts: 23
Unread post Re: TWGS in Windows 7 x64 (service)
I tried logged in as Administrator and run as administrator and neither one works. Now, twgsserv.exe will install as a service and run, but it will not show up in the taskbar. I also ran netstat -a to look for the ports, and they are not listed.

I have tried this as administrator, run as admin, and compatibility mode (WIN XP P3).

I also have tried running this from the services list. It says that it is started, but again nothing in the taskbar and no ports listed.


Fri Jun 10, 2011 11:23 am
Profile
Veteran Op
User avatar

Joined: Thu Jun 02, 2005 2:00 am
Posts: 5558
Location: USA
Unread post Re: TWGS in Windows 7 x64 (service)
If you're running it as a service, it never will show up in the task bar. When ran as a service, it has no GUI session to bind to and thus you will never get a task bar icon. Unless the app takes special care to provide a separate management GUI (most don't), service apps don't provide GUI controls.

What you want, it sounds, is to run it from the GUI. To do this, set your system to boot into the admin user and load twgs from the start folder. That is the way most of us run it.

_________________
May the unholy fires of corbomite ignite deep within the depths of your soul...

1. TWGS server @ twgs.navhaz.com
2. The NavHaz Junction - Tradewars 2002 Scripts, Resources and Downloads
3. Open IRC chat @ irc.freenode.net:6667 #twchan
4. Parrothead wrote: Jesus wouldn't Subspace Crawl.

*** SG memorial donations via paypal to: dpocky68@booinc.com
Image


Fri Jun 10, 2011 12:26 pm
Profile ICQ WWW
Site Admin
User avatar

Joined: Sun Dec 24, 2000 3:00 am
Posts: 3150
Location: USA
Unread post Re: TWGS in Windows 7 x64 (service)
TWGS won't show up in the task tray for Windows 2008 and Windows 7. I wasn't able to get that functioning properly under those OSs, so it's been deferred until I have one to test on. But if you don't see the port listed, and you can't telnet in, then it's clearly not running.

I've been working with Micro to troubleshoot some things on his Windows 7 machine. We're using a service called join.me that allows you to create a url link and send it to me so I can open a virtual window on your desktop from a browser. Pretty easy to do. I'd like to find someone who's experiencing this problem who'd be willing to let me poke around and try to find a solution. We were not able to reproduce this issue on Micro's Windows 7 64 bit machine, so it's not a problem to everyone in general who's running Windows 7 and TWGS as a service. My only hope of reproducing the bug may be to observe it on one of my customer's machines.

_________________
John Pritchett
EIS
---
Help fund the TradeWars websites! If you open a hosting account with A2 Hosting, the service EIS uses for all of its sites, EIS will earn credits toward its hosting bill.


Fri Jun 10, 2011 12:28 pm
Profile WWW
Veteran Op
User avatar

Joined: Thu Jun 02, 2005 2:00 am
Posts: 5558
Location: USA
Unread post Re: TWGS in Windows 7 x64 (service)
I have windows 2008 R2 running as a testbed machine for AD and sharepoint. I can turn it on, setup RDP, and you can install TWGS on it if you want. It's virtualbox, so I can take snapshots for restore.

_________________
May the unholy fires of corbomite ignite deep within the depths of your soul...

1. TWGS server @ twgs.navhaz.com
2. The NavHaz Junction - Tradewars 2002 Scripts, Resources and Downloads
3. Open IRC chat @ irc.freenode.net:6667 #twchan
4. Parrothead wrote: Jesus wouldn't Subspace Crawl.

*** SG memorial donations via paypal to: dpocky68@booinc.com
Image


Fri Jun 10, 2011 3:51 pm
Profile ICQ WWW
Site Admin
User avatar

Joined: Sun Dec 24, 2000 3:00 am
Posts: 3150
Location: USA
Unread post Re: TWGS in Windows 7 x64 (service)
I haven't had any reports of this being a problem on 2008. Just Windows 7. If you can verify that you have the same problem installing as a service on 2008, then that would definitely help.

_________________
John Pritchett
EIS
---
Help fund the TradeWars websites! If you open a hosting account with A2 Hosting, the service EIS uses for all of its sites, EIS will earn credits toward its hosting bill.


Fri Jun 10, 2011 3:59 pm
Profile WWW
Veteran Op

Joined: Thu Jun 09, 2011 9:40 pm
Posts: 23
Unread post Re: TWGS in Windows 7 x64 (service)
I stand corrected. My mistake, it will not show up in the task bar (oops sorry). But I also looked for the ports and the ports were not open on my machine.

The program will install as a service, it says it has started, but it does not run or open up the ports. I have also tried using apptosvc from Basta Computing to start it as a service and that will not work either.


Fri Jun 10, 2011 4:02 pm
Profile
Site Admin
User avatar

Joined: Sun Dec 24, 2000 3:00 am
Posts: 3150
Location: USA
Unread post Re: TWGS in Windows 7 x64 (service)
When you started the server, you said you got a 1053 error, which means TWGS failed to identify itself as a service. It's probably something related to TWGS, but I've seen a lot of reports on the net about lots of services exhibiting this behavior. Something changed in the way services are started.

_________________
John Pritchett
EIS
---
Help fund the TradeWars websites! If you open a hosting account with A2 Hosting, the service EIS uses for all of its sites, EIS will earn credits toward its hosting bill.


Fri Jun 10, 2011 4:05 pm
Profile WWW
Lieutenant J.G.

Joined: Mon Feb 26, 2001 3:00 am
Posts: 438
Location: In your girlfriend's bed
Unread post Re: TWGS in Windows 7 x64 (service)
Running win 7, I'm getting the same issue. Says I have to be logged in as an admin also. I'm already an admin.

Do I have to go back to my slower Win XP machine?


Fri Feb 17, 2012 10:04 pm
Profile
Site Admin
User avatar

Joined: Sun Dec 24, 2000 3:00 am
Posts: 3150
Location: USA
Unread post Re: TWGS in Windows 7 x64 (service)
No. This is an ongoing issue with Windows 7. Windows 7 won't run an application with admin rights unless you tell it to run with elevated privileges, even if you're on an admin account. So TWGS currently won't run on Win7 unless you run as administrator.

I actually made a change to the upcoming version where TWGS no longer tests for admin privileges, it just attempts to do whatever it needs to do that only an admin can do, and errors out with a message if it fails. This gets around the "you can only run as an admin" message when running under an admin account. The OS reports to TWGS that you're not an admin, but if you are an admin, TWGS has access to the needed resources, so all is well. Hopefully that'll cure this issue once and for all.

For now, if you set the "run as administrator" option on the TWGS Service icon, it should work.

_________________
John Pritchett
EIS
---
Help fund the TradeWars websites! If you open a hosting account with A2 Hosting, the service EIS uses for all of its sites, EIS will earn credits toward its hosting bill.


Fri Feb 17, 2012 11:27 pm
Profile WWW
Lieutenant J.G.

Joined: Mon Feb 26, 2001 3:00 am
Posts: 438
Location: In your girlfriend's bed
Unread post Re: TWGS in Windows 7 x64 (service)
Got it to run. Thanks.

Once I figure out all the new menus and options, I'll start my beta testing.


Sat Feb 18, 2012 7:07 am
Profile
Site Admin
User avatar

Joined: Sun Dec 24, 2000 3:00 am
Posts: 3150
Location: USA
Unread post Re: TWGS in Windows 7 x64 (service)
I looked at getting the service to start without being run as "run as administrator" last night, and unlike TWGS itself, it won't install the service. So I guess the only solution is to provide better instructions in the error message, describing how to set the shortcut to "run as administrator". It would be nice if I could just install the shortcut with that setting enabled, but I can't figure out a way.

_________________
John Pritchett
EIS
---
Help fund the TradeWars websites! If you open a hosting account with A2 Hosting, the service EIS uses for all of its sites, EIS will earn credits toward its hosting bill.


Sat Feb 18, 2012 12:40 pm
Profile WWW
Lieutenant J.G.

Joined: Mon Feb 26, 2001 3:00 am
Posts: 438
Location: In your girlfriend's bed
Unread post Re: TWGS in Windows 7 x64 (service)
Yeah. Just make more people aware of this and as long as there is always a work around like that, it should not be a problem.


Sat Feb 18, 2012 6:56 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 15 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware.